Custom 3D mesh

Submit here any suggestion
Bibou
Posts: 7
Joined: Sat Apr 25, 2009 5:24 pm

Post by Bibou » Wed Sep 09, 2009 3:28 pm

J'ai un soucis et je pense que sa vient du faite que le fichier est au format .MSH et que les autres fichier sont au format .MESH !!! non

wock
Posts: 20
Joined: Tue Aug 25, 2009 7:41 pm

Post by wock » Wed Sep 09, 2009 3:53 pm

Ben renomme-le en .mesh

Bibou
Posts: 7
Joined: Sat Apr 25, 2009 5:24 pm

Post by Bibou » Wed Sep 09, 2009 6:28 pm

et bien le probleme c'est que ça a l'air d'tre de format differnet car Windows ne me propose meme pas de le remplacer

George Levandis
Posts: 156
Joined: Wed May 13, 2009 2:51 pm
Location: Volos-Greece
Contact:

Post by George Levandis » Thu Sep 10, 2009 8:24 am

Hi wock.It's George.
Can you please tell me how did you exactly managed to edit the mesh files?Please tell me. :D 8) :lol:

wock
Posts: 20
Joined: Tue Aug 25, 2009 7:41 pm

Post by wock » Thu Sep 10, 2009 7:29 pm

Hi George. It's wock
wock wrote:To edit the .mesh files with blender you will need:
-http://www.ogre3d.org/forums/viewtopic.php?t=45922
(blender exporter)

- http://people.freenet.de/3-D-Man-Zone/d ... mporter.py
(importer, got on: http://www.ogre3d.org/forums/viewtopic.php?f=8&t=9135)

-http://sourceforge.net/project/download ... i&89692520
(tools to convert .mesh files in .xml files)


1) Paste the importer and exporter files in the script folder of blender
2) Install the command line tools wherever you want
3) Run blender:
delete all the default objects
import > ogre 3d mesh importer
always put scale at 100%
specify where is your ogre xml converter
choose your .mesh file
"ok"
wait a little
exit
the object should be in blender

to export:
export> ogre meshes> deactivate "export materials" > activate" xml converter " and "fix y axis" , go in preferences to specify where is the xml converter

you're done
what more do you want?
you have to go in edit mode and you musn't move the sides in width or depth, only in height
just give it a fex tries and you should understant quite quickly how it works.


et bibou tu peux toujours modifier le format, suffit d'aller dans outils > options des dossiers > décoche masquer les fichiers dont l'extension est connue.
Ou alors j'ai rien compris à ton problème :lol:

George Levandis
Posts: 156
Joined: Wed May 13, 2009 2:51 pm
Location: Volos-Greece
Contact:

Post by George Levandis » Tue Oct 20, 2009 6:04 pm

wock wrote:To edit the .mesh files with blender you will need:
-http://www.ogre3d.org/forums/viewtopic.php?t=45922
(blender exporter)

- http://people.freenet.de/3-D-Man-Zone/d ... mporter.py
(importer, got on: http://www.ogre3d.org/forums/viewtopic.php?f=8&t=9135)

-http://sourceforge.net/project/download ... i&89692520
(tools to convert .mesh files in .xml files)


1) Paste the importer and exporter files in the script folder of blender
2) Install the command line tools wherever you want
3) Run blender:
delete all the default objects
import > ogre 3d mesh importer
always put scale at 100%
specify where is your ogre xml converter
choose your .mesh file
"ok"
wait a little
exit
the object should be in blender

to export:
export> ogre meshes> deactivate "export materials" > activate" xml converter " and "fix y axis" , go in preferences to specify where is the xml converter

you're done
What means when it tells me that the value is too high?Also when i am going to import a mesh file it sails than the is an error in the python script.Can someone help me please?

wock
Posts: 20
Joined: Tue Aug 25, 2009 7:41 pm

Post by wock » Wed Oct 21, 2009 7:07 am

I don't remember exactly because I haven't been using it for a long time but I think you have to put the mesh files in root folders like directly in "C:/" because the script doesn't work with long paths.
I'm in vacations in a few days I'll try to help you but you can still go and check out the topics about importers and exporters on the ogre forum (links in my previous posts).
Hoping it will solve your problem :wink:

George Levandis
Posts: 156
Joined: Wed May 13, 2009 2:51 pm
Location: Volos-Greece
Contact:

Post by George Levandis » Sun Oct 25, 2009 4:09 pm

I have blender 2.49.When i am trying to import a mesh(files-import-ogre 3d mesh importer)it sais that there is an error in the python script.Can someone help me please????????I want to edit the mesh files.Can you help me???wock????Is bledner 2.49 the problem??what????????Please answer me the sooner. :( :)

xander
Posts: 50
Joined: Sun Oct 25, 2009 3:17 pm

Post by xander » Sun Oct 25, 2009 7:18 pm

man i just instal it it's sick, but you dont can ride it

umpljn
Posts: 207
Joined: Sat Sep 05, 2009 7:54 pm
Location: Essen, Germany
Contact:

Post by umpljn » Sun Oct 25, 2009 7:24 pm

you have to use version 1.12

xander
Posts: 50
Joined: Sun Oct 25, 2009 3:17 pm

Post by xander » Sun Oct 25, 2009 7:27 pm

umpljn wrote:you have to use version 1.12
if i install it , the big wave doesn't appear

wock
Posts: 20
Joined: Tue Aug 25, 2009 7:41 pm

Post by wock » Sun Oct 25, 2009 9:24 pm

george, could you tell me what is written in the command line windows when you get this error? (the one with a black background and white text)

xander
Posts: 50
Joined: Sun Oct 25, 2009 3:17 pm

Post by xander » Sun Oct 25, 2009 9:54 pm

if i install 1.12 can i ride the wave then?

George Levandis
Posts: 156
Joined: Wed May 13, 2009 2:51 pm
Location: Volos-Greece
Contact:

Post by George Levandis » Sun Oct 25, 2009 10:50 pm

At leats!!!!!!!!!!!!!1I managed to put the mesh files in blender.Now my question is.How i can edit them in height,width e.t.c.?Please tell me.
8) 8) 8)

wock
Posts: 20
Joined: Tue Aug 25, 2009 7:41 pm

Post by wock » Sun Oct 25, 2009 11:42 pm

there are many ways to do it, here's a very simple one I found out:
go in edit mode,
first I recommend you to select all vertices and using the smooth tool to reduce the bumps (don't do it to much 'cause if the water gets too flat the guy won't be able to ride it )
then choose the side view (so you will see a line) and select a few vertices in the center using B key
once you've done this if you get in top view you should see the selected vertices form a rectangle,
get back in side view,
find the proportional edit falloff icon:
Image
put it on connected or on as you want, then choose the type of falloff you want ( I recommend Smooth falloff or Sharp falloff )
then press G key, a circle will appear (you might not see it at first because your object is very big) and use your mouse roll to change it's size, this defines the influence of the deformation you are about to do, only the vertices in the circle will be modified.
finally you can use the classic move and rotate tools to create your wave's geometry and size.

Give it a few tries before trying anything complicated so you can figure out the size and the orientation of your wave in the game etc.
of course if you find other easy ways to create waves or other stuff please share :wink:

Post Reply